cisco_ospf路由重分布和虚链路的配置

微信扫一扫,分享到朋友圈

cisco_ospf路由重分布和虚链路的配置

需求:

1、R1、R2、R3、R4的f0/0接口分别配置100.1.1.1-4并启动ospf路由协议加入area 0

2、R1、R2、R3、R4分别配置回环接口1.1.1.1、2.2.2.2、3.3.3.3、4.4.4.4;分别加入area 1、area 2、area 3、area 4

3、R2的f0/1和R5的f0/0接口改为p2p,不选举DR/BDR

4、R5和R6上配置rip协议,在R5上配置路由重分布

5、在R3和R7上配置静态路由,在R3上配置路由重分布

6、在R4和R8之间配置虚链路,使R9可以学习area 0里的路由

拓扑:

 

配置:

R1的配置:

interface loopback 0ip address1.1.1.1 255.255.255.255
interface f0/0ip address100.1.1.1 255.255.255.0no shutdown
router ospf1router-id 1.1.1.1network100.1.1.0 0.0.0.255  area 0network1.1.1.1 0.0.0.0 area 1

R2的配置:

interface loopback 0ip address2.2.2.2 255.255.255.255
interface f0/0ip address100.1.1.2 255.255.255.0no shutdowninterface f0/1ip address25.1.1.2 255.255.255.0no shutdown
ip ospf network point-to-point  #更改接口为p2p模式
router ospf1router-id 2.2.2.2network100.1.1.0 0.0.0.255 area 0network2.2.2.2 0.0.0.0 area 2network25.1.1.0 0.0.0.255  area 2

R3的配置:

interface loopback 0ip address3.3.3.3 255.255.255.255
interface f0/0ip address100.1.1.3 255.255.255.0no shutdowninterface f0/1ip address37.1.1.3 255.255.255.0no shutdown
router ospf1router-id 3.3.3.3network100.1.1.0 0.0.0.255  area 0network3.3.3.3 0.0.0.0 area 3ip route7.7.7.7 255.255.255.255 37.1.1.7  #配置静态路由
router ospf1redistributestatic subnets metric 1     #将静态路由重分布到ospf里
redistribute connected subnets          #将直连路由重分布到ospf里

R4的配置:

interface loopback 0ip address4.4.4.4 255.255.255.255
interface f0/0ip address100.1.1.4 255.255.255.0no shutdowninterface f0/1ip address48.1.1.4 255.255.255.0no shutdown
router ospf1router-id 4.4.4.4network100.1.1.0 0.0.0.255  area 0network4.4.4.4 0.0.0.0 area 4network48.1.1.0 0.0.0.255 area 4
area4 virtual-link 8.8.8.8        #配置虚链路

R5的配置:

interface loopback 0ip address5.5.5.5 255.255.255.255
interface f0/0ip address25.1.1.5 255.255.255.0no shutdown
ip ospf network point-to-point      #更改接口为p2p模式interface f0/1ip address56.1.1.5 255.255.255.0no shutdown
router ospf1router-id 5.5.5.5network25.1.1.0 0.0.0.255  area 2router rip
version2no auto-summary
network5.5.5.5network56.1.1.0redistribute ospf1 subnets metric 3      #将ospf重分布到rip里
router ospf1redistribute rip subnets metric100  #将rip重分布到ospf里 

R6的配置:

interface loopback 0ip address 6.6.6.6255.255.255.255
interface f0/0ip address 56.1.1.6 255.255.255.0no shutdown
router rip
version 2no auto-summary
network 6.6.6.6 network 56.1.1.0

 R7的配置:

interface loopback 0ip address7.7.7.7 255.255.255.255
interface f0/0ip address37.1.1.7 255.255.255.0no shutdown
ip route0.0.0.0 0.0.0.0 37.1.1.3   #配置静态路由

 R8的配置:

interface loopback 0ip address8.8.8.8 255.255.255.255
interface f0/0ip address48.1.1.8 255.255.255.0no shutdowninterface f0/1ip address89.1.1.8 255.255.255.0no shutdown
router ospf1router-id 8.8.8.8network8.8.8.8 0.0.0.0 area 4network48.1.1.0 0.0.0.255 area 4network89.1.1.0 0.0.0.255 area 5area4 virtual-link 4.4.4.4      #配置虚链路 virtual-link为对端路由器的route-id

R9的配置:

interface loopback 0ip address9.9.9.9 255.255.255.255
interface f0/0ip address89.1.1.9 255.255.255.0no shutdown
router ospf1router-id 9.9.9.9network9.9.9.9 0.0.0.0 area 5network89.1.1.0 0.0.0.255 area 5

 

 

 

 

 

 




 

 

cisco_ospf路由重分布和虚链路的配置

原文地址:https://www.cnblogs.com/Ziorayx/p/13714873.html

红衫、碧桂园抢投的秦淮数据赴美上市 老虎证券任分销商0费用打新通道已开启

上一篇

Ubuntu 配置 Sha-dow-socks

下一篇

你也可能喜欢

cisco_ospf路由重分布和虚链路的配置

长按储存图像,分享给朋友