Eclipse 4.17启动提示:JVM is not suitable for this

微信扫一扫,分享到朋友圈

Eclipse 4.17启动提示:JVM is not suitable for this

通过是修改eclipse.ini文件,在eclipse.ini文件上加上添加一行代码:
-vm 指定jdk11下bin的路径

如下代码
-startup
plugins/org.eclipse.equinox.launcher_1.5.800.v20200727-1323.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.1300.v20200819-0940
-product
org.eclipse.epp.package.jee.product
-showsplash
org.eclipse.epp.package.common
--launcher.defaultAction
openFile
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vm
C:/Program Files/java/jdk11.0.5/bin
-vmargs
-Dosgi.requiredJavaVersion=11
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
--add-modules=ALL-SYSTEM
-Dosgi.requiredJavaVersion=11
-Dosgi.dataAreaRequiresExplicitInit=true
-Xms256m
-Xmx2048m
--add-modules=ALL-SYSTEM

Eclipse 4.17启动提示:JVM is not suitable for this

原文地址:https://blog.51cto.com/1929297/2536173

记一次linux 内存异常的处理

上一篇

Linux-CentOS Samba无法访问或新建文件夹

下一篇

你也可能喜欢

Eclipse 4.17启动提示:JVM is not suitable for this

长按储存图像,分享给朋友