getty 1.3 版本发布,兼容 JDK1.7、Android 5.0 以上版本

微信扫一扫,分享到朋友圈

getty 1.3 版本发布,兼容 JDK1.7、Android 5.0 以上版本

本次更新

  1. 添加对java nio1的支持。
  2. 部分网友表示希望兼容更低jdk版本,特别是Android 5.0以上版本的支持(Getty 1.3以下版本使用了部分jdk8的特征,在安卓8.0以下不支持)。本次更新主要是对在JDK1.8以下环境以及Android8.0 以下环境下使用做了兼容。
  3. 优化了部分代码,提高了稳定性。

getty

一个完全基于java 实现的高性能网络框架。

简介

1、getty是完全基于java nio封装的高性能网络框架。

2、getty可在项目中使用,也可以用于帮助你更好的学习java nio

3、getty完全开源,基于 Apache License 2.0 开源协议。

4、getty的目的是为了降低对java socket nio的使用成本,帮助提高工作效率。

getty的特点:

1、完全基于java nio,基于nio1以及nio2(aio)做了实现,整体代码代码结构很轻量,也非常简单易用。

2、借鉴了netty和其他框架的部分优秀设计思想,如责任链、内存池化、零拷贝等优秀的设计模式。

3、getty提供了常用的多个插件(String编解码器,protobuf编解码器器,心跳超时处理器、ip过滤,websocket插件等)满足大部分开发场景。

4、getty可直接在安卓环境中使用(兼容Android5.0以上版本)

5、getty同时提供了TCP和UDP的支持,并且使用方式几乎一致,大大提高了易用性。

5、getty内置处理器支持使用过程中的热拔插设计,各处理器可以灵活组合。

6、框架拥有非常好的拓展性,处理器拓展也非常简单,大大降低了开发成本。

7、高效和稳定性能,经过多次测试,同时发送百万消息的耗时居然比netty还好。

相同的条件下发送百万条消息,getty 使用nio2模式耗时500毫秒左右,使用nio1模式耗时1.5秒左右,netty耗时2.5秒左右(没有黑netty的意思,也许是netty做了很多其他的处理)。

8、使用过程与netty非常相似,只要有netty是使用经验,使用getty几乎不需要额外学习。

更多详情与文档

更多详情,请点击 wiki文档
跳转到wiki

提供bug反馈或建议

create by

gogym

因食品杂货订单激增 亚马逊将再次提升仓库工人工资

上一篇

意外“暴露”身高:雷军晒Redmi智能电视MAX 98寸真机合影

下一篇

你也可能喜欢

getty 1.3 版本发布,兼容 JDK1.7、Android 5.0 以上版本

长按储存图像,分享给朋友